FreeDev
Site développé avec WebDev
Accueil
 Les codes free de FreeDev
[WinDev][22] Comment récupérer une adresse depuis des coordonnées GPS dans WinDev

Voici donc un exemple de code :

Info(Geo2Adresse(43.639942,3.837672))

PROCEDURE Geo2Adresse(rLatitudeOrigine est un réel, rLongitudeOrigine est un réel)

sFormulaireGoogleMaps est une chaîne="FormulaireGoogleMaps"

sURL est une chaîne = "http://maps.googleapis.com/maps/api/geocode/xml"

HTTPCréeFormulaire(sFormulaireGoogleMaps)

HTTPAjouteParamètre(sFormulaireGoogleMaps,"latlng",NumériqueVersChaîne(rLatitudeOrigine, ".6f")+","+NumériqueVersChaîne(rLongitudeOrigine, ".6f"))

HTTPAjouteParamètre(sFormulaireGoogleMaps,"sensor","false")

SI PAS HTTPEnvoieFormulaire(sFormulaireGoogleMaps,sURL,httpGet) ALORS

RENVOYER ""

SINON

xmlResultatGoogleMaps est un xmlDocument

sResultatHTTP est une chaîne = HTTPDonneRésultat(httpRésultat)

xmlResultatGoogleMaps=XMLOuvre(sResultatHTTP,depuisChaîne)

SI ErreurDétectée ALORS

Erreur(ErreurInfo())

SINON

SI xmlResultatGoogleMaps.GeocodeResponse.status~= "OK" ALORS

POUR TOUT xmlUnResulat DE xmlResultatGoogleMaps.GeocodeResponse

SI xmlUnResulat..Nom ~= "result" ALORS

SI xmlUnResulat.type ~= "route" ALORS

RENVOYER xmlUnResulat.formatted_address

FIN

FIN

FIN

FIN

FIN

FIN

RENVOYER ""

Faites des économies facilement, pensez iGraal :

J'utilise personnellement iGraal (cliquez sur le bandeau de pub à droite de ce texte).
Cela m'a permis
après inscription gratuite et installation de la barre iGraal dans le navigateur de récupérer plusieurs centaines d'euros lors de mes différents achats sur Internet (matériel à la FNAC, réservation d’hôtels chez Booking.com ou Hotels.com, achat sur la Redoute …)

C'est un vrai bon plan qui ne nécessite aucun engagement. Vous recevez ensuite le chèque à votre domicile ou un virement sur votre compte bancaire.

Il vous suffit d’installer la barre iGraal et de l’activer avant chaque achat.

Inscrivez-vous
Code Wlangage
RECHERCHE